Are You Ready?

New cyber security measures required by the PCI Security Standards Council are rolling out in the months ahead that will require certain standards in Browsers and Operating Systems in order to engage in any ecommerce. Whether you engage with patients, banks, freight carriers, airlines, distributors, or even Amazon – you will need to ensure your Browser and OS are of a sufficient level by February 17, 2018. Click here for more information.

Note: You can log on to another device/computer and check the operating system and browser versions by using the same links above.